Forums

Site Feedback

Welcome to Live View – Take the tour to learn more
Start Tour
There is currently 1 person viewing this thread.
Knight Rider
05 Dec 12 00:48
Joined:
Date Joined: 22 Jun 02
| Topic/replies: 7,474 | Blogger: Knight Rider's blog
Very confusing.  Thought the bet hadn't gone through.  Tried it again and it only did £5.  Then realised I had £55 matched.  This has happened a few times since the upgrade.  It's as if the site cannot process the numbers quick enough if you press 'Submit' straight away.  This is obviously quite a challenge when betting in-play.

Anyone else had the same problem?  I am on Chrome.
Pause Switch to Standard View I just bet £50 instead of £5000
Show More
Loading...
Report laughingmike December 5, 2012 12:24 PM GMT
I use Chrome and have had LOADS of problems SUBMITTING bets, CHANGING bets, CANCELLING bets.

The site is virtually unusable at the moment :-(
Report dan33 December 10, 2012 9:24 AM GMT
I have had the same problem Knight Rider - it's an issue I've raised with Betfair and mentioned several times on the forum. It makes the new site unusable for in-play trading.

They phoned me about it a couple of months ago, but a fix has still not been implemented. Glad, in a way, that someone else has experienced the same issue. Chrome is my browser of choice as well, but I've tested it on Firefox and IE - the problem is consistent regardless of browser.
Report dan33 December 10, 2012 9:27 AM GMT
And here's a screencast of it happening, if anyone from Betfair is looking in: http://screencast.com/t/DnYEFFeQiD4H
Report Betfair Community Manager 2 December 11, 2012 7:46 AM GMT
dan - thanks for the screencast. I have shared that with the people working on this. I believe we are aware and working on a fix, but always best to play safe.
Post Your Reply
<CTRL+Enter> to submit
Please login to post a reply.

Wonder

Instance ID: 13539
www.betfair.com